Bug report #6700

refresh button does not work as expected in browser in qgis master

Added by Giovanni Manghi almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Browser
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:15865

Description

I believe this is a regression, because I don't see this issues in qgis 1.8

There are cases where the refresh button has no effect:

I just tried to drag and drop a shape from a system folder into a postgis connection, for some reason the process returned and error. After that the postgis connection is no more available, as the connection name is shown, but it does not show any of the schemas in it. Hitting refresh has no effect, the only way out is restart qgis.

This also happens when deleting a layer from a postgis schema, in 1.8 you can then hit "refresh" and have the list updated, in master it just does not show anymore any layer in any schema. And hitting refresh does not work.

I believe I have seen this issue with other oprations, but right now are the ones I remember.

History

#1 Updated by Giovanni Manghi almost 7 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Also available in: Atom PDF