Bug report #670

terraserver WMS getcapabilities not understood

Added by neteler-itc-it - over 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Magnus Homann
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:RedHat Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10729

Description

Hi,

when accessing
http://terraserver.microsoft.com/ogccapabilities.ashx

QGIS is segfaulting...

Best,
Markus

History

#1 Updated by Magnus Homann over 13 years ago

  • Status changed from Open to In Progress

Are you using trunk or 0.8 branch?

#2 Updated by anonymous - over 13 years ago

The HEAD version, so trunk, updated right now.
Ah, it no longer segfaults but returns to the
menu. Very good.

Changing the topic to "terraserver WMS getcapabilities not understood".

After clicking "connect", I get

Could not understand the response.  The wms provider said:

The file returned from
http://terraserver.microsoft.com/ogccapabilities.ashx
looks like XML to me (maybe not valid WMS?).

Markus

#3 Updated by Magnus Homann over 13 years ago

For me, it returns a list of layers. No errors there. This is both in latest trunk and 0.8 branch.

The layers do not draw, however.

#4 Updated by Marco Hugentobler about 13 years ago

The problem is that terraserver uses different urls for GetCapabilities and GetMap:

http://terraserver.microsoft.com/ogccapabilities.ashx

and

http://terraservice.net/ogcmap.ashx

In my opinion, this is a strange interpretation of the WMS specification. Should qgis support several urls? I think if it is only terraserver, then not. If there are more wms servers like this out there, then probably yes.

#5 Updated by Tom Kralidis almost 12 years ago

Replying to [comment:5 mhugent]:

The problem is that terraserver uses different urls for GetCapabilities and GetMap:

http://terraserver.microsoft.com/ogccapabilities.ashx

and

http://terraservice.net/ogcmap.ashx

In my opinion, this is a strange interpretation of the WMS specification. Should qgis support several urls? I think if it is only terraserver, then not. If there are more wms servers like this out there, then probably yes.

Yes, this is strange, but legal. FWIW, in practice, I think this is one of the only WMS endpoints I've seen configured like this.

#6 Updated by Martin Dobias almost 12 years ago

Apparently the URL has changed in meanwhile, now at: http://terraserver-usa.com/ogccapabilities.ashx

But the problem persits... for me it doesn't crash, just doesn't show any raster.

URL for GetMap request is advertised in GetCapabilities answer in element Capability -> Request -> GetMap -> DCPType -> HTTP -> Get -> OnlineResource

#7 Updated by Tom Kralidis almost 12 years ago

Replying to [comment:8 wonder]:

Apparently the URL has changed in meanwhile, now at: http://terraserver-usa.com/ogccapabilities.ashx

But the problem persits... for me it doesn't crash, just doesn't show any raster.

URL for GetMap request is advertised in GetCapabilities answer in element Capability -> Request -> GetMap -> DCPType -> HTTP -> Get -> OnlineResource

Correct. The bulletproof thing to do would be to invoke a GetCapabilities request, pick up this value and use that as the GetMap server URL.

#8 Updated by Martin Dobias almost 12 years ago

  • Status changed from In Progress to Closed
  • Resolution set to fixed

fixed in by Vita Cizek - thanks for contribution!

#9 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF