Bug report #6660

Import and drop table problem

Added by Luca Lanteri almost 8 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:DB Manager
Affected QGIS version:master Regression?:No
Operating System:WINDOWS Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:15837

Description

Some problem with DBManager plugin during import data from postgres to spatialite.

when I drop a table and I try to import a new table with the same name the plugin says "table already exist":
  1. import a table
  2. drop the table
  3. import the table again
during import if I try to drop the table checking "drop existing one" the import seems to work but some geometry were lost.
  1. import a table
  2. modify some geometry in source table
  3. import table again checking "drop existing one"

History

#1 Updated by Luca Lanteri over 7 years ago

In order to bypass the problem is it possible to open the database with spatialite-gui, delete the table and optimize the database.

#2 Updated by Giuseppe Sucameli over 7 years ago

The problem is due to the connection QGis keeps opened.

#3 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#4 Updated by Luca Lanteri over 2 years ago

Tested on QGIS 3.0. It works fine from browser but the problem persists from dbmanager.

#5 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed
  • Description updated (diff)

Also available in: Atom PDF