Bug report #6621

TopoGeometry editing broken when using CTID as primary key

Added by Sandro Santilli almost 8 years ago. Updated almost 8 years ago.

Status:Closed
Priority:Normal
Assignee:Sandro Santilli
Category:Data Provider/PostGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15806

Description

The latest TopoGeometry editing code, in the part where the id of the newly created TopoGeometry is updated, fails in that it uses CTID as a primary key but since we're updating the table the CTID changed since we looked at it...

Associated revisions

Revision 8c391922
Added by Sandro Santilli almost 8 years ago

Only change the TopoGeometry definition, not its reference, on edit

Refactor the TopoGeometry editor to avoid touching the edited table
and directly act on the topology relation instead. Fixes #6621 but
also generally makes less writes to the database.

History

#1 Updated by Sandro Santilli almost 8 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF