Bug report #6611

converting OSM file to shp losses data in the procees

Added by baditaflorin - almost 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:15799

Description

I have a OSM file for Romania, created using osmconvert from pbf.

and i load the osm data into Qgis using Openstreetmap plugin
i do right click on the points layer, save as ersi shapefile

After i load the data a lot of data gets lost in the process.

You can see from the attached files that in second example, the tag attribute misses a lot of data, making it useless for statistics.

And i cannot use the osm file because with 60000 objects inside, it`s moving to slow.
The SHP file haves great speed, but it has this bug too.

conversie_osm_shp_2.jpg - first it`s the original OSM file (117 KB) baditaflorin -, 2012-11-02 01:26 PM

conversie_osm_shp.jpg - Second it`s the shp file that i created from the osm file (104 KB) baditaflorin -, 2012-11-02 01:26 PM

History

#1 Updated by Giovanni Manghi over 6 years ago

  • Status changed from Open to Feedback

please attach sample data.

#2 Updated by Giovanni Manghi over 6 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

shapefile have a 255 char limit for columns width, so not a qgis bug, but a format limitation. If you need to preserve all the data then you will need to export in a more advanced format, like spatialite or postgis.

Also available in: Atom PDF