Bug report #6589

spatial join plugin ftools gives wrong results

Added by johan sanders about 8 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Processing/QGIS
Affected QGIS version:master Regression?:
Operating System:w7 64bit Easy fix?:
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:15780

Description

when joining two polygone shape files through "spatial join" (ftools) the resulting atrribute table of the new shapefile is wrong : the spatialy identical attributes from the two shape files are not joined together and no error message is shown

when using the "intersection of 2 shapefiles " this gives a correct result for the spatially identically located polygones

the two shapes are landuse parcels with each appr 200000 polygones
some polygones in the first are not found in the second shapefile

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

The spatial join ("join attributes by location") and the intersection operation are different, and it seems you needed really the intersection.

Please reopen if necessary, but then attach sample data and explain in details the expected results.

#2 Updated by Giovanni Manghi over 3 years ago

The "ftools" category is being removed from the tracker, changing the category of this ticket to "Processing/QGIS" to not leave the category orphaned.

Also available in: Atom PDF