Bug report #6569

Print crash

Added by Francesco Barsotti almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:wontfix
Crashes QGIS or corrupts data:No Copied to github as #:15767

Description

I created a print layout: two maps and two rectangles. The map contains only one layer. When I chose the "export as pdf" option, I read this message (after a few seconds) "bad allocation". The pdf is not produced. If I try to chose the "export as image" option, qgis shuts down, without any message. Don't know how to solve this...

OS Windows XP SP 3

Intel(R) Core(TM)2 Duo CPU
E8400 @ 3.00 GHz
3.00 GHz, 3.25GB Ram

Prova.qgs (25.3 KB) Francesco Barsotti, 2012-11-02 06:23 AM

pai_pi10k_EPSG3003_Adb_Arno.dbf (49.6 KB) Francesco Barsotti, 2012-11-02 06:23 AM

pai_pi10k_EPSG3003_Adb_Arno.sbn (84.8 KB) Francesco Barsotti, 2012-11-02 06:23 AM

pai_pi10k_EPSG3003_Adb_Arno.sbx (3.69 KB) Francesco Barsotti, 2012-11-02 06:23 AM

pai_pi10k_EPSG3003_Adb_Arno.shx (66.1 KB) Francesco Barsotti, 2012-11-02 06:23 AM

History

#1 Updated by Giovanni Manghi almost 7 years ago

  • Target version set to Version 2.0.0
  • Category set to 33
  • Status changed from Open to Feedback

please attach sample data

#3 Updated by Giovanni Manghi almost 7 years ago

Francesco Barsotti wrote:

Here is the sample!

the .shp file is missing

#4 Updated by Francesco Barsotti almost 7 years ago

The file is more than 5MB so I send you a link to the sample data. The link is operating one week.
thanks

https://www.yousendit.com/download/WUJic0x4Z1BlM1J2Zk1UQw

#5 Updated by Giovanni Manghi almost 7 years ago

Francesco Barsotti wrote:

The file is more than 5MB so I send you a link to the sample data. The link is operating one week.
thanks

https://www.yousendit.com/download/WUJic0x4Z1BlM1J2Zk1UQw

I also got a crash using qgis master and "layout3", but I then switched to new symbology and then it worked without issue.

Please test your project with A) qgis master and B) switching to new symbology

and then report back.

#6 Updated by Francesco Barsotti almost 7 years ago

I tried without Qgis Master but with the new symbology and it works.
I didn't try with qgis master because I actually don't know how to install (am I supposed to select the "Download OSGEO4W Installer" in the download page?).
However, the old symbology seems to be the matter
Thanks
Francesco

#7 Updated by Giovanni Manghi almost 7 years ago

  • Resolution set to wontfix
  • Status changed from Feedback to Closed

Francesco Barsotti wrote:

I tried without Qgis Master but with the new symbology and it works.
I didn't try with qgis master because I actually don't know how to install (am I supposed to select the "Download OSGEO4W Installer" in the download page?).
However, the old symbology seems to be the matter
Thanks
Francesco

then I'll close the ticket because the old symbology reached the end of the line, and very soon will be removed from QGIS.

#8 Updated by Jürgen Fischer almost 7 years ago

Francesco Barsotti wrote:

I tried without Qgis Master but with the new symbology and it works.
I didn't try with qgis master because I actually don't know how to install (am I supposed to select the "Download OSGEO4W Installer" in the download page?).
However, the old symbology seems to be the matter

Or the old labeling (especially the buffering).

Also available in: Atom PDF