Bug report #6550

Fix sip bindings to QgsVectorLayer signals featureAdded / featureDeleted

Added by Rafael Varela about 8 years ago. Updated about 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15754

Description

Trying to connect() a signal handler for featureAdded I get this error:

@TypeError: connect() failed between 'featureAdded' and 'unislot'@

My code looks like this:

vLayer.featureAdded.connect(self.onNodeFeatureAdded)

...

@pyqtSlot(int)
def onNodeFeatureAdded(featureId):
...
return

I guess that the sip bindings for featureAdded() and featureDeleted() should be changed the same way was done for geometryChanged() and attributeValueChanged() in commit 32978fb4e9a6b115bed3245a90c4c038ed3fb04c

i.e:

void featureAdded( QgsFeatureId fid );
void featureDeleted( QgsFeatureId fid );

instead of:

void featureAdded( qint64 fid );
void featureDeleted( qint64 fid );

Associated revisions

Revision dbab4a24
Added by Jürgen Fischer about 8 years ago

update QgsVectorLayer bindings (fixes #6550)

History

#1 Updated by Jürgen Fischer about 8 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF