Bug report #6425

Inaccurate counts of heavily overlapping points

Added by Aren Cambre almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:15671

Description

I have a PostGIS table with a geometry column with nothing but points. Due to a problem with my geocoder, I have 39,859 points that have the exact same position. I have verified that with this query:

SELECT COUNT(*)
FROM raw.geocoding
WHERE the_geom = (SELECT the_geom
FROM raw.geocoding
WHERE hash='9e96a550f3db90733910faa8e40b6907')

When I load the dataset in QGIS, I use Select Features by Rectangle to draw a box around these points, and on the bottom left, I see 9375 feature(s) selected on layer geocoding. (geocoding is my layer name.) I should instead see 39859 for the count.

History

#1 Updated by Aren Cambre almost 7 years ago

  • Priority changed from High to Normal
  • Status changed from Open to Closed

Disregard. I screwed up.

#2 Updated by Aren Cambre almost 7 years ago

  • Resolution set to invalid

Also available in: Atom PDF