Bug report #637

QGIS Crash when WMS getcap fails

Added by spatialguru-shaw-ca - over 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10696

Description

  • I've built qgis_unstable from source
  • I "add default services" for WMS
  • Selected server connection "DM Solutions GMAP" and press "connect"
  • Message pops up saying:
    Could not understand the response. The wms provider said:
    WMS Server responded unexpectedly with HTTP Status Code 502 (Proxy Error)
    Tried URL: http://www2.dmsolutions.ca/cgi-bin/mswms_gmap?SERVICE=WMS&REQUEST=GetCapabilities
  • I press "close" then QGIS crashes

Let me know if there are more tests I can do. Same action with Lizardtech connection. JPL ones seem to work fine.
Dump report from apple tool is attached.
Tyler

qgis_wms_crash.txt Magnifier - dump report of wms crash (24.5 KB) spatialguru-shaw-ca -, 2007-03-04 11:46 PM

History

#1 Updated by Magnus Homann over 13 years ago

Did you specify a proxy host?

#2 Updated by spatialguru-shaw-ca - over 13 years ago

No, I left proxy host empty as I do not use one. It is the same as the other entries that work.

#3 Updated by anonymous - over 13 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Confirmed, homann's fix https://svn.qgis.org/trac/changeset/6768 worked for me. Thanks.

#4 Updated by Anonymous about 11 years ago

Milestone Version 0.9 deleted

Also available in: Atom PDF