Bug report #6302

QGIS WFS Server Geometry Type not recognize by ArcGIS

Added by René-Luc ReLuc about 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:René-Luc ReLuc
Category:QGIS Server
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15598

Description

After the resolution of #6116, Giovanni Manghi testing QGIS WFS Server with GvSIG, uDIG and ArcGIS.

ArcGIS doesn't recognize the Geometry Type, because ArcGIS uses DescribeFeatureType to identifying Geometry Type and QGIS WFS Server return that geometry is just GeometryPropertyType.

6302 - Patch for this Bug (1.69 KB) René-Luc ReLuc, 2012-09-04 09:28 AM

6302_v2 - Patch V2 (15.4 KB) René-Luc ReLuc, 2012-09-18 12:04 AM

50.png (64.5 KB) Giovanni Manghi, 2012-09-26 11:25 AM

51.png (60 KB) Giovanni Manghi, 2012-09-26 11:25 AM


Subtasks

Bug report #6485: QGIS WFS Server GML is not validClosedRené-Luc ReLuc


Related issues

Related to QGIS Application - Bug report #6116: QGIS WFS server doesn't work with uDIG and Arcgis as clients Closed 2012-07-28

History

#1 Updated by René-Luc ReLuc about 7 years ago

#3 Updated by Giovanni Manghi about 7 years ago

  • Pull Request or Patch supplied changed from No to Yes

#4 Updated by René-Luc ReLuc about 7 years ago

In addition to indicate the geometry type in the DescribeFeatureType request, this patch adds boundedBy to FeatureCollection and Feature element.

#5 Updated by Giovanni Manghi about 7 years ago

René-Luc ReLuc wrote:

In addition to indicate the geometry type in the DescribeFeatureType request, this patch adds boundedBy to FeatureCollection and Feature element.

thanks! I will try it asap. Can you make a pull request on github?

#6 Updated by René-Luc ReLuc about 7 years ago

commit 593da452193f31d3941b56a64369c692b866bf40
for patch V2

#7 Updated by Giovanni Manghi about 7 years ago

René-Luc ReLuc wrote:

commit 593da452193f31d3941b56a64369c692b866bf40
for patch V2

Hi René-Luc,

I have just installed qgis master and made a simple WFS service, then tested it with Arcgis 9.3 with the data interoperability extension.

When creating the connection AG shows the layer list correctly, but then it just show a "no geometry". See attached images.

#8 Updated by René-Luc ReLuc about 7 years ago

This new commit "0ddc034968065046f301d260900d6e9fa46d2ef0":commit:0ddc034968065046f301d260900d6e9fa46d2ef0 probably solved tue issue

#9 Updated by Giovanni Manghi about 7 years ago

René-Luc ReLuc wrote:

This new commit "0ddc034968065046f301d260900d6e9fa46d2ef0":commit:0ddc034968065046f301d260900d6e9fa46d2ef0 probably solved tue issue

Hi Again René-Luc,

I just tested again the latest QGIS master available in the nightly build repo, and unfortunately still no joy with AG as WFS client.

The issue is always the same, it shows the table list, but then when establishing the connection (to actually choose what layer to add to the project) it just says "no geometry".

cheers!

#10 Updated by René-Luc ReLuc over 6 years ago

Giovanni Manghi : does the bug still exists ?

#11 Updated by René-Luc ReLuc over 6 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Also available in: Atom PDF