Bug report #6253

Multi attribute editing - Only one value checked results in error

Added by Matthias Kuhn about 8 years ago. Updated about 8 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:Data Provider/PostGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15559

Description

When editing the attribute table of a vector layer with the multi attribute editing tool an array should be generated to be inserted into postgresql. This array is formatted as {1,2,3}.
If only one value is inserted, the array should be {1}. But if only one value is checked (which is not the first one in the list) the resulting array looks like this: {,3}. This is not accepted by postgresql.

The attached patch solves this problem. Please review and apply.

0001-Fix-multi-attribute-editing-in-value-relation-bug-wh.patch Magnifier (1.16 KB) Matthias Kuhn, 2012-08-27 04:49 AM

Associated revisions

History

#1 Updated by Andreas Neumann about 8 years ago

  • Assignee set to Jürgen Fischer

#2 Updated by Jürgen Fischer about 8 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF