Bug report #625

Unknown svn revision in win32 preview2

Added by Magnus Homann over 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10684

Description

The svn revison doesn't work in win32 preview 2. I suspect there is an old qgssvnversion.h in the source directory that's picked up before the one in build directory where the binary is build. It works for me otherwise.

History

#1 Updated by Magnus Homann over 13 years ago

Solution is that one have to have svn command line inertafce tools installed for this to work, specifically 'svnversion'.

#2 Updated by Redmine Admin over 13 years ago

has this been solved with preview3? should it be closed?

#3 Updated by Magnus Homann over 13 years ago

No, still not build with svn cmd line tools installed on the build machine.

#4 Updated by Tim Sutton over 13 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Im building with svn cli tools now. Svn version is showing up correctly now. Closing this bug - thanks!

Tim

#5 Updated by Anonymous about 11 years ago

Milestone Version 0.8.1 deleted

Also available in: Atom PDF