Bug report #6195

Scalebar in print composer always set to last-added map

Added by bnotter - about 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:Normal
Assignee:Marco Hugentobler
Category:-
Affected QGIS version:master Regression?:No
Operating System:Windows 7/Ubuntu 12.04 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15509

Description

If a print composer in QGIS has several maps (e.g. a main map and one or several inset maps) and one scalebar (usually valid for the main map), the scalebar will, after closing and opening the project, always be set to the scale of the map added last to the print composer. E.g., if the main map was added first, it is called Map 0 in the dropdown list under "element properties" of the scalebar. The map added second is called Map 1 and the next one Map 2 etc. If the map chosen for the scale bar was Map 0, and then the project is closed and opened again, the map shown in the dropdown list after opening is Map 2 or whichever map was added last; the scale bar also indicates distances corresponding to that last-added map. It has to be set back to Map 0 manually.
When looking at the .qgs project file, the reason for this behavior becomes evident - the property to which map the scalebar corresponds is not saved.
It would be good if this issue could be fixed since it can get annoying to always have to set the map for the scalebar correctly again when opening a project to export/print a map.

Anteile_Stop_Go_Bericht.qgs - Example .qgs project (56.5 KB) bnotter -, 2012-08-14 06:57 AM

History

#1 Updated by Marco Hugentobler about 7 years ago

  • Assignee set to Marco Hugentobler

#2 Updated by Marco Hugentobler about 7 years ago

  • Status changed from Open to Closed

Should be fixed in master branch (778e7d735ba8156d6fae55cd1faed77f01f09642)

Also available in: Atom PDF