Bug report #6172

QGIS freezes when deleting features from big PostGIS table

Added by Serge Dikiy about 8 years ago. Updated about 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15489

Description

Hi,

I have PostGIS table with 10e6 features. "Scale dependent" is set to display only 100-500 features. All work very fast..

But, if I want delete some features... QGIS freezes... because QGIS gets all 10e6 features from PostGIS.

See attachment.(test table have only 60 features)

BR.

qgis_del_Feature.txt Magnifier (28.6 KB) Serge Dikiy, 2012-08-08 01:12 PM

Associated revisions

Revision 2ab02218
Added by Jürgen Fischer about 8 years ago

recalculate vector layer extent only when necessary (fixes #6172)

History

#1 Updated by Jürgen Fischer about 8 years ago

  • Category changed from Data Provider/PostGIS to Vectors

Not a postgres provider problem. After features are deleted, the layer extents are recalculated by iterating all not deleted features.

#2 Updated by Jürgen Fischer about 8 years ago

  • Status changed from Open to Closed

#3 Updated by Serge Dikiy about 8 years ago

Thank you, jef
Everything works great!

Also available in: Atom PDF