Bug report #6143

Field Calculator - No update existing field option available for PostGIS layer

Added by Tom Joseph about 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Vectors
Affected QGIS version:master Regression?:No
Operating System:Windows, Linux (Ubuntu) Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:15471

Description

There is no update existing field option available for a postgis vector layer when not logged on as the table owner.

After a quick scan of qgsfieldcalculator.cpp (line 46-51) I see that if the data provider does not support field addition it disallows existing field edits with mUpdateExistingGroupBox->setCheckable( false );. Should that not read mNewFieldGroupBox->setCheckable( false ); ?

Expected result - Limit some users to only update data and not the ability to create new fields. Editing data for these users works as expected using the attribute form on an individual features but not multiple row updates in the Field Calculator.


Related issues

Duplicates QGIS Application - Bug report #6120: Field calculator doesn't disable field addition, when lay... Closed 2012-07-30

History

#1 Updated by Giovanni Manghi about 7 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #6120

Also available in: Atom PDF