Bug report #613

SRID of PostGIS layers not recognized

Added by hartmut-tschauner-gmail-com - over 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:Data Provider
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10672

Description

Hello,

Every PostGIS layer loaded into 0.8.1 Windows preview 1 comes in without SRID, although the underlying PostGIS geometries do have SRIDs and the tables have entries with SRID in the geometry_columns table. If I dismiss the prompt for a projection without choosing one, however, the metadata page of the layer's Properties will report the correct PostGIS coordinate system.

History

#1 Updated by Magnus Homann over 13 years ago

What happens if you set any other options for projections, such as using global setting or project setting?

Is there a PostGIS layer we could test on?

#2 Updated by Tim Sutton over 13 years ago

Changed version to 0.8.0 since version 0.8.1 is not released yet...

#3 Updated by leolami - over 12 years ago

Can you test it in 0.9.2 and close it if all is right?
Thank you

#4 Updated by leolami - over 12 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

I close it. If you think it is still valid reopen it, please.

#5 Updated by Anonymous about 11 years ago

Milestone Version 0.9.2 deleted

Also available in: Atom PDF