Bug report #6101

User not warned of uncommited edits when closing

Added by Chris Crook about 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:master Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:15446

Description

Steps to reproduce:
1) Open a new project
2) Add an editable layer (I've tried memory and shapefile).
3) Save the project
4) Make the layer editable, add some features (Do not save edits or end editing the layer)
5) Close QGIS (saving the project if prompted) - Note: no prompt to save uncommitted edits
6) Reopen the project. Added features have disappeared.

I've confirmed this using
QGis 1.8.0a on Ubuntu 11.10
QGis 1.8.0RC1 on Windows XP


Related issues

Duplicates QGIS Application - Bug report #6054: QGIS 1.8 doesn't warn about unsaved changes in layers on ... Closed 2012-07-17

History

#1 Updated by Giovanni Manghi about 7 years ago

  • Status changed from Open to Feedback

isn't this a duplicate of #6054 ?

#2 Updated by Chris Crook about 7 years ago

Indeed it is ... I tried searching for a matching issue, but missed it :-(

#3 Updated by Giovanni Manghi about 7 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Chris Crook wrote:

Indeed it is ... I tried searching for a matching issue, but missed it :-(

no problem.

Closing as duplicate.

Also available in: Atom PDF