Bug report #6017

Qgis builds broken histrogram if input src image contains <no-data> values

Added by Nikos Ves over 8 years ago. Updated over 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:15402

Description

I've calculated an enviromental index, and because of the input data many pixes of the final product contain many <no-data> values. When I load the image to qgis, and tabing to histogram page, the resulting histogram is unsualble due the large amount of chaff. Picture attached.

http://dl.dropbox.com/u/2464313/2000_n_combined.tif

broken-hist.JPG (71.9 KB) Nikos Ves, 2012-07-11 08:52 AM

History

#1 Updated by Nikos Ves over 8 years ago

I also attach a dropbob link for the source image I used.

#2 Updated by Giovanni Manghi over 8 years ago

  • Status changed from Open to Feedback
  • Category set to Rasters

isn't this a duplicate of #1380 ? If yes, please close this ticket as duplicate.

#3 Updated by Nikos Ves over 8 years ago

seems to be the same

#4 Updated by Giovanni Manghi over 8 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

Nikos Ves wrote:

seems to be the same

duplicate of #1380

Also available in: Atom PDF