Bug report #5917

QGIS crashes when digitizing vector sets

Added by andre mano over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System:Windows 7 Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:15358

Description

When digitizing features to a vector layer with topological errors, QGIS crashes. However, this seems to only happen if "Avoid intersection" option is on. "Snapping" and "Topological editing" options do not seem to interfere.

The problem occurs in QGIS Master, 1.8, and in 1.7.4 too.
Attached goes a Screencast depicting the problem and also the polygon layer in wich the problem occurs.

BTW if I clean the topology in GRASS, QGIS no longer crashes as long as one maintains topological integrity while digitizing.

Default.rar - Vector layer (208 KB) andre mano, 2012-06-30 08:58 AM

Screencast.rar - Screencast (2.43 MB) andre mano, 2012-06-30 08:58 AM


Related issues

Duplicates QGIS Application - Bug report #5584: QGIS crashes saving a vector with an empty geometry Closed 2012-05-13
Duplicates QGIS Application - Bug report #5824: QGIS silently fails to add a geometry using "avoid inters... Closed 2012-06-18

History

#1 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Hi Andre,

now I see the issue you were talking to me.

This issue is duplicate of #5584 and #5824.

As far I can see under Linux it doesn't fail silently to add the new geometry but instead throws a warning message, so on the subsequent save there is no crash as not empty geometry was added. So this seems at least a Windows only issue.

Also available in: Atom PDF