Bug report #5847

Setting Options>Rendering>Contrast Enhancement has no effect.

Added by cgsbob - over 8 years ago. Updated over 8 years ago.

Status:Closed
Priority:Normal
Assignee:Marco Hugentobler
Category:Rasters
Affected QGIS version:master Regression?:No
Operating System:64bit Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15317

Description

I'm on master e816b37. When I loaded a 32 bit geotiff, it was rendered in grey. I changed Options>Rendering>Contrast Enhancement to "Stretch and clip to MinMax", and loaded another geotiff and it was grey too.

So, I quit qgis and restarted it, then verified that Options>Rendering>Contrast Enhancement was still set to "Stretch and clip to MinMax". I loaded a geotiff and once again it is rendered grey. The rasters Style>Contrast Enhancement displays "No Enhancement" and the min/max displays as -3.40282e+38/3.40282e+38. Changing the Style>Contrast Enhancement to "Stretch and clip to MinMax" and load the actual (or estimated) min/max gives me a min/max of 2.56715/1911.83, and the raster is rendered into a nice grey scale image.

Here is info on my raster:

$ gdalinfo -mm cat_dem.tif
Driver: GTiff/GeoTIFF
Files: cat_dem.tif
       cat_dem.tif.ovr
       cat_dem.tif.aux.xml
Size is 9890, 7065
Coordinate System is:
PROJCS["NAD83 / California zone 5",
    GEOGCS["NAD83",
        DATUM["North_American_Datum_1983",
            SPHEROID["GRS 1980",6378137,298.2572221010002,
                AUTHORITY["EPSG","7019"]],
            TOWGS84[0,0,0,0,0,0,0],
            AUTHORITY["EPSG","6269"]],
        PRIMEM["Greenwich",0],
        UNIT["degree",0.0174532925199433],
        AUTHORITY["EPSG","4269"]],
    PROJECTION["Lambert_Conformal_Conic_2SP"],
    PARAMETER["standard_parallel_1",35.46666666666667],
    PARAMETER["standard_parallel_2",34.03333333333333],
    PARAMETER["latitude_of_origin",33.5],
    PARAMETER["central_meridian",-118],
    PARAMETER["false_easting",6561666.666666667],
    PARAMETER["false_northing",1640416.666666667],
    UNIT["US survey foot",0.3048006096012192,
        AUTHORITY["EPSG","9003"]]]
Origin = (6373218.661568500101566,1636985.589801950147375)
Pixel Size = (9.842519699999997,-9.842519699999997)
Metadata:
  AREA_OR_POINT=Area
Image Structure Metadata:
  INTERLEAVE=BAND
Corner Coordinates:
Upper Left  ( 6373218.662, 1636985.590) (118d37' 4.67"W, 33d29'20.33"N)
Lower Left  ( 6373218.662, 1567448.188) (118d36'59.64"W, 33d17'52.53"N)
Upper Right ( 6470561.181, 1636985.590) (118d17'55.53"W, 33d29'24.72"N)
Lower Right ( 6470561.181, 1567448.188) (118d17'53.10"W, 33d17'56.91"N)
Center      ( 6421889.921, 1602216.889) (118d27'28.24"W, 33d23'39.00"N)
Band 1 Block=9890x1 Type=Float32, ColorInterp=Gray
  Description = lariac_dem
  Min=-7.394 Max=2103.129   Computed Min/Max=-7.394,2103.129
  Minimum=-7.394, Maximum=2103.129, Mean=660.177, StdDev=495.194
  NoData Value=-3.4028234663852886e+38
  Overviews: 4945x3533, 2473x1767, 1237x884, 619x442, 310x221, 155x111, 78x56
  Metadata:
    LAYER_TYPE=athematic
    RepresentationType=athematic
    STATISTICS_MAXIMUM=2103.1293945312
    STATISTICS_MEAN=660.17715431802
    STATISTICS_MINIMUM=-7.3936886787415
    STATISTICS_STDDEV=495.19442690445

History

#1 Updated by Marco Hugentobler over 8 years ago

  • Status changed from Open to Closed

Fixed now in master (duplicate of ticket #5797)

Also available in: Atom PDF