Bug report #5832

QGIS seg fault when loading a project with a missing CSV datasource

Added by Giovanni Manghi about 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:15307

Description

I tested (on 1.8) also other missing datasources and no crash, but it shows the following messages


ERROR 4:
`/media/436dc38a-c791-4a29-92e8-1506d42f2a9d/gio/UBC_filipe/dem_move_clipped.tif' does not exist in the file system,
and is not recognised as a supported dataset name.

or


ERROR 10: Pointer 'hDS' is NULL in 'OGR_DS_Destroy'.

I'm pretty sure that this is a regression and so the ticket should be tagged as "blocker", but I cannot test 1.7.4 right now, so if someone can give it a try I would appreciate.


Related issues

Related to QGIS Application - Bug report #6119: EVIS: invalid layer in project Closed 2012-07-30
Duplicates QGIS Application - Bug report #5809: Segmentation fault when data source deleted or moved Closed 2012-06-16
Duplicates QGIS Application - Bug report #6034: Impossible to open the .qgs file I've just saved with QGI... Closed 2012-07-13

History

#1 Updated by Giovanni Manghi about 7 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #5809

Also available in: Atom PDF