Bug report #5831

Qgis very slow on selecting/identifing polygons with lots of vertices

Added by Pietro Rossin over 8 years ago. Updated over 8 years ago.

Status:Closed
Priority:High
Assignee:-
Category:-
Affected QGIS version:1.8.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:15306

Description

Hi all
Qgis version 1.8 and master (480c860) on my desktop (xp 32bit) get very slow when a polygon with lots of vertices is selected or identified (with the "i" key) (It was the same with 1.7.4, I just upgraded).
To select/identify a complex polygon (shp file)it takes a lot of time and after the selection Qgis slows down a lot. No other action can be done before unselecting it, otherwise qgis hangs and I have to force quit it.
If the polygon with lots of vertices is unselected then qgis resumes its speed.
It happens only with complex polygons, because if I select/ident. a simpler polygon coming from the same shp file qgis works perfect.
I saw that a similar problem was with the edit vertices funcion and it was solved, I don't know if this issue is known.
Thanks for your work
Pietro

History

#1 Updated by Giovanni Manghi over 8 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #4819

Also available in: Atom PDF