Bug report #5828

WMS-C support broken in QGIS master

Added by Giovanni Manghi over 7 years ago. Updated about 7 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15303

Description

I'm testing one beside the other QGIS 1.8 and Master, and it seems that in master the support of WMS-C servers is broken (e.g. tilecache).

Using the following server

http://mapas.igeo.pt/tilecache/tilecache.py?

and both "Ignore getMap..." and "Ignore FeatureInfo..." checked.

Seems a consequence of the raster resampling merge.

Associated revisions

History

#1 Updated by Jürgen Fischer over 7 years ago

Not reproducable here. I tried the basic layer (with IgnoreGetMapUrl checked) - seems normal.

#2 Updated by Giovanni Manghi over 7 years ago

Jürgen Fischer wrote:

Not reproducable here. I tried the basic layer (with IgnoreGetMapUrl checked) - seems normal.

Hi Jurgen,

you have to try one of the other layers, one not in WGS84 CRS, for example carta_500000 (other layers may not show at certain scales as the server is configured to serve the maps only in a specified scale interval. But the layer carta_500000 is good to see the issue).

#3 Updated by Salvatore Larosa over 7 years ago

confirmed here using a different layer!
with basic layer works!

I get this (with IgnoreGetMap checked):

Tile request failed [error:Error downloading http://mapas.igeo.pt/tilecache/tilecache.py?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&WIDTH=256&HEIGHT=256&LAYERS=MDT50m&STYLES=&FORMAT=image/png&SRS=EPSG:102161&TILED=true&BBOX=-170000.0000000000000000,-320000.0000000000000000,135000.0000000000000000,-15000.0000000000000000 - server replied: Not Found url:http://mapas.igeo.pt/tilecache/tilecache.py?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&WIDTH=256&HEIGHT=256&LAYERS=MDT50m&STYLES=&FORMAT=image/png&SRS=EPSG:102161&TILED=true&BBOX=-170000.0000000000000000,-320000.0000000000000000,135000.0000000000000000,-15000.0000000000000000]

#4 Updated by Jürgen Fischer over 7 years ago

  • Subject changed from Tilecache WMS support broken in QGIS master to WMS-C support broken in QGIS master

#5 Updated by Jürgen Fischer over 7 years ago

  • Priority changed from Severe/Regression to High

#6 Updated by Giovanni Manghi over 7 years ago

but regressions should not be tagged as blockers? Anyway there is a long way before the next release, but at least we can easily see what must be fixed before it.

#7 Updated by Marco Hugentobler about 7 years ago

  • Assignee deleted (Marco Hugentobler)

This is not caused by the resampler branch. I did a git reset to revision ff87deef0702fdde21764b0f8588b402448eb6df (so just before the resampler merge) and at this stage the bug is already there.

#8 Updated by Giovanni Manghi about 7 years ago

  • Priority changed from High to Severe/Regression

#9 Updated by Jürgen Fischer about 7 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF