Bug report #5800

Problem with legend icon when using line pattern fill

Added by Victor Axbom over 7 years ago. Updated over 6 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:15290

Description

If you are using the line pattern fill, you will only see the lines in the layer legend icon and the composer legend icon if you use a quite small distance between the lines. A larger distance between the lines results in a failure to visualize the pattern since you will only see one line or no line of the full pattern. See attached screenshots

linepattern_legend_icon.JPG - Incomplete layer legend icon (58.4 KB) Victor Axbom, 2012-06-14 06:29 AM

linepattern_composer_legend_icon.JPG - and in the composer legend (3.52 KB) Victor Axbom, 2012-06-14 06:29 AM

History

#1 Updated by Marco Hugentobler about 7 years ago

  • Status changed from Open to Feedback

Couldn't you just increase the symbol width and height in composer to see more lines? In my opinion, that's the proper solution here as the distance between the lines must be the same in legend as in map.

#2 Updated by Victor Axbom over 6 years ago

  • Status changed from Feedback to Closed

You are right, that's probably the best solution.

Marco Hugentobler wrote:

Couldn't you just increase the symbol width and height in composer to see more lines? In my opinion, that's the proper solution here as the distance between the lines must be the same in legend as in map.

Also available in: Atom PDF