Bug report #573

upgrade to titan but it won't start as I get a segmentation fault

Added by bshcm03-yahoo-co-uk - over 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Magnus Homann
Category:Build/Install
Affected QGIS version: Regression?:No
Operating System:Fedora Easy fix?:No
Pull Request or Patch supplied: Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:10632

Description

I have upgraded to titan but QGIS will no longer start - I get a segmentation fault on start up. I was able to use the previous version (with intermittent errors).

I have created (and attached) log files for configure, make and make install. I was getting a qt4 error but this was resolved after I chagned the qt4 installation directory from default to /usr/local/qt4

I ideally run qgis from within grass (grass 6.2.1) but cannot do this either.

I was getting some make install warnings,but not errors.

Do you have any thoughts?

If you need any further information etc, please do not hesitate to ask.

Thanks

config.log Magnifier (40.7 KB) bshcm03-yahoo-co-uk -, 2007-02-06 04:29 AM

make.log Magnifier (16.9 KB) anonymous -, 2007-02-06 04:32 AM

make.install.log Magnifier (164 KB) bshcm03-yahoo-co-uk -, 2007-02-06 04:34 AM

config.2.log Magnifier - My config.log (96.4 KB) Magnus Homann, 2007-02-06 07:57 AM

config.3.log Magnifier - log file generated by ./configure (91.2 KB) bshcm03 -, 2007-02-07 12:59 AM

bh.make.check.log Magnifier - make check output with error message (164 KB) bshcm03 -, 2007-02-07 01:02 AM

config.4.log Magnifier - latest config.log (91.4 KB) bshcm03 -, 2007-02-08 01:54 AM

qgis_error_8-2-07 - debug output at startup before segmentation fault (8.83 KB) bshcm03 -, 2007-02-08 01:56 AM

History

#1 Updated by Magnus Homann over 13 years ago

  • Status changed from Open to In Progress

When you run ./configure, a file named config.log is automatically created. This is my config.log which doesn't look like yours. Did you pipe the output of configure to config.log?

Around line 10, you can see how I configured it. QT and GRASS is probably needed. If you still have problems, use --enable-debug to give us some hints when running.

What is the revision of the source? Tar-ball or from SVN?

#2 Updated by anonymous - over 13 years ago

Replying to [comment:1 homann]:

When you run ./configure, a file named config.log is automatically created. This is my config.log which doesn't look like yours. Did you pipe the output of configure to config.log?

Around line 10, you can see how I configured it. QT and GRASS is probably needed. If you still have problems, use --enable-debug to give us some hints when running.

What is the revision of the source? Tar-ball or from SVN?

Thanks for looking at this. The correct config.log is now attached - you were right about how the previous one was generated.

I am using Tar-ball source downloaded yesterday so the version is 0.8.0

I have checked the config.log file as best I can and can't seem to see any errors or warnings. I tried running make clean then make check after running ./configure again and I got errors. My piped log file for make check is also attached. At the end of this log file I have included the error message which was displayed.

Any more thoughts?

#3 Updated by bshcm03 - over 13 years ago

I have progressed a little: configure now completes and config log is attached. Make also completes withour error and make install completes without errors. I fixed the paths to qt4 and installed gsl. But, when I run qgis from the command line, I still get a segmentation fault. The debug output is attached as qgis error 8-2-07

Can you have a look at this information and suggest some more things to try.

Thanks.

#4 Updated by Magnus Homann over 13 years ago

Hmm...

It crashes while loading plugins/providers/widgets from /usr/lib/qgis/. It loads them in alphabetical order, so you could try remove libqgsprojectionselector.so/.a and then proceed in alphabetical order... :-)

Have you double-checked you are using x64 version of all libs? Try ldd on both 'qgis' and all the plugins in /usr/lib/qgis/, to see what they link to.

Also try starting qgis in gdb, and supply backtrace.

You are not the only one with problems on x64, se #563

#5 Updated by anonymous - over 13 years ago

Replying to [comment:4 homann]:

Hmm...

It crashes while loading plugins/providers/widgets from /usr/lib/qgis/. It loads them in alphabetical order, so you could try remove libqgsprojectionselector.so/.a and then proceed in alphabetical order... :-)

Have you double-checked you are using x64 version of all libs? Try ldd on both 'qgis' and all the plugins in /usr/lib/qgis/, to see what they link to.

Also try starting qgis in gdb, and supply backtrace.

You are not the only one with problems on x64, se #563

Thanks - it now works. This is what I did.

I followed all the steps you suggested above and using gdb helped me to identify the problem. This is what I did (for the benefit of others)

prompt> gdb

(gdb) run /usr/bin/qgis

the error occured when it tried to run something from the directory /usr/lib64/qt3-3

I renamed this directory /usr/lib64/qt3-3bu and then restared qgis. It loaded and now seems to be working fine.

I renamed to directory back to /usr/lib64/qt3-3 so that I could recreate the error to provide you with better feedback but I cannot recreate the problem.

Problem solved. Thanks for your help.

#6 Updated by Magnus Homann over 13 years ago

  • Status changed from In Progress to Closed
  • Resolution set to invalid

Sounds like the wrong Qt runtime libraries got picked up. Not a bug in Qgis, but glad to help! :-)

#7 Updated by Anonymous about 11 years ago

Milestone Version 0.8.1 deleted

Also available in: Atom PDF