Feature request #558

Highlight Layers

Added by Redmine Admin over 12 years ago. Updated over 7 years ago.

Status:Closed
Priority:Low
Assignee:-
Category:GUI
Pull Request or Patch supplied:No Resolution:worksforme
Easy fix?:No Copied to github as #:10617

Description

Allow the user to create layers on the fly where the layer shows a circular or rectangular area. These areas can either be 'drawn' on screen using the mouse, based on a radius or distance from a given lat/long, or based around a point source in a vector layer. The user should be able to also select the colour/texture and give the ayer a name.

I would use this for identifying/highlighting areas of interest.

History

#1 Updated by Tim Sutton about 11 years ago

Sounds like a nice idea for a plugin. I'm putting this against milestone 2.0.0 though since its not something we will have time to implement within 1.0 release.

Regards

Tim

#2 Updated by alobo - about 10 years ago

I would add allowing the user to rotate the feature,
i.e., drawing an initial rectangle of a given size that could be interactively refined afterwards,
including rotation. I think that this would be best included within the Edit tools.
Agus

#3 Updated by Giovanni Manghi about 10 years ago

The latest request seems partially a duplicate of #1787. I leave this note for the developers, for when they will a look at this enhancement.

#4 Updated by Giovanni Manghi over 7 years ago

  • Status changed from Open to Feedback
  • Pull Request or Patch supplied set to No
  • Assignee deleted (nobody -)

on the fly layers -> in memory layers plugin

draw regular shapes -> rectangles, ovals, diamond plugin / cad tools plugin

"or based around a point source in a vector layer" -> buffer tool in the vector menu

"The user should be able to also select the colour/texture and give the ayer a name" -> you can also for in memory layers

"I would use this for identifying/highlighting areas of interest" -> spatial query tool

I vote to close this ticket, feedback needed.

#5 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

Closing for lack of feedback and considered that the request is doable on QGIS with the available tools/plugins. Reopen if necessary.

Also available in: Atom PDF