Bug report #5542

Rule based symbology refine assistant can't read values for fields with special characters

Added by Regis Haubourg over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:1.7.4 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15135

Description

This bug is related to #5536

Tested with Qgis 1.7.4 standalone and qgis 1.8.0 from osgeow.

When trying to refine rules in rule based labeling interface, if field names contain spaces or non ascii characters, range or category classify assistant can't read values of fields and sets values to 0.
I guess this is because in code field name is not set with quotation marks since we have same problem in #5536. Anyone confirms?

Cheers
régis

bug_refine_rules_values.jpg (42.8 KB) Regis Haubourg, 2012-05-04 01:33 AM

History

#1 Updated by Hugo Mercier over 7 years ago

Yes, it is linked to the #5536

#2 Updated by Martin Dobias over 7 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

fixed in bf86521d4

Also available in: Atom PDF