Bug report #538

delimited text plug-in lets QGIS crash on windows

Added by timmichelsen-gmx-topmail-de - almost 14 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10597

Description

When unsing the delimited text plug-in with a semicolon separated file QGIS show a error window with no text. There's a button to shut down QGIS.

In the last preview it worked well.

History

#1 Updated by Magnus Homann almost 14 years ago

Is this in the pre-compiled version downloaded from qgis?
Do you have a sample file to attach?

Thanks.

#2 Updated by timmichelsen-gmx-topmail-de - almost 14 years ago

Is this in the pre-compiled version downloaded from qgis?

Yes, this one: http://download.qgis.org/qgis/win32/qgis-0.8.0_setup.exe

Do you have a sample file to attach?

Sorry, I can't. The work is confidential. Please mail if you can't reproduce I will replace the information in the text file by dummy information.
The file has about 6000 datasets.

#3 Updated by Magnus Homann almost 14 years ago

I can reproduce this with this input file:

----
X;Y
0;0
----

It works with 10.000 lines of similar data in trunk, however. I have no possiblity to debug 0.8 on win32, unfortunately.

#4 Updated by Magnus Homann almost 14 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

It was a problem with malformed lines, such as an extra line break at the end of dataset. If any line has less than 2 fields, it would crash. Fixed by .

#5 Updated by Anonymous over 11 years ago

Milestone Version 0.8.1 deleted

Also available in: Atom PDF