Feature request #5319

Performance issues with new symbology and levels

Added by cremat0rio - over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:15022

Description

I'm using QGis 1.7.3 (the same happens on 1.7.1).

With a polygon layer, and the new symbology with levels, QGis gets very slow and only uses one thread (it seems so), wich is strange nowadays with multicore processors.

History

#1 Updated by Giovanni Manghi over 9 years ago

  • Status changed from Open to Closed
  • Resolution set to duplicate

duplicate of #3388

#2 Updated by Giovanni Manghi over 9 years ago

  • Resolution deleted (duplicate)
  • Status changed from Closed to Feedback

sorry I didn't see that #3388 was already closed. Anyway you will need to provide sample data and further information to allow investigate if/where there is an issue.

#3 Updated by cremat0rio - over 9 years ago

Sorry, there's no issue.
Horizontal placement, in "Layer labeling settings", was inadvertently selected.
Sorry.

#4 Updated by Giovanni Manghi over 9 years ago

cremat0rio - wrote:

Sorry, there's no issue.
Horizontal placement, in "Layer labeling settings", was inadvertently selected.
Sorry.

so the issue is in labelling?

#5 Updated by cremat0rio - over 9 years ago

Going to Labeling -> Advanced -> Placement, there are various options.
"Horizontal" specifically states "slow".
So this is not a bug, maybe a feature request.

#6 Updated by Giovanni Manghi over 9 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

cremat0rio - wrote:

Going to Labeling -> Advanced -> Placement, there are various options.
"Horizontal" specifically states "slow".
So this is not a bug, maybe a feature request.

work is being done to make labelling faster, especially with polygons.

Also available in: Atom PDF