Bug report #5303

SQL Server new provider , select fails

Added by Eric Mariage over 8 years ago. Updated about 8 years ago.

Status:Closed
Priority:Normal
Assignee:Tamas Szekeres
Category:Data Provider
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:15009

Description

Using the new SQL server provider with geometry table, it's not possible to have the attribut datas in the window 'attribut table' of QGIS.
We got only "ERROR" on every row.
It's not possible to select on feature on the map, if we click on one all features are selected.
We try several SQL server table and got always the same problem.

History

#1 Updated by Eric Mariage over 8 years ago

The problem comes from a column in uniqueIdentifier. The only format for the key seems to be integer.

#2 Updated by Tamas Szekeres over 8 years ago

  • Assignee set to Tamas Szekeres

#3 Updated by Tamas Szekeres over 8 years ago

  • Status changed from Open to Feedback

Feature id in QGIS can only be 64 bit in size. The SQL uniqueidentifier type (which is 16 bytes) not sufficient for this purpose. Use int or bigint data types for the feature id column.

#4 Updated by Jürgen Fischer about 8 years ago

  • Resolution set to worksforme
  • OS version deleted (1.9.90)
  • Status changed from Feedback to Closed

seems solved - closing for the lack of feedback

Also available in: Atom PDF