Bug report #53

Large markers are downscaled to the global iconSize in the legend

Added by Marco Hugentobler almost 14 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Map Legend
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10112

Description

Large point markers are not displayed in the correct size in the legend. This is because the qt4 QTreeWidget uses QIcon for the legend images. QTreeWidget has a member iconSize, which is valid for all items (in contrast to the qt3 ListView which allowed different icon sizes for different items). A solution could be to keep track of how large the images of all items are and change the global icon size when items are added / removed.

History

#1 Updated by Marco Hugentobler almost 14 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

The legend does now adapt the global icon size to the largest item pixmap.

#2 Updated by Anonymous over 10 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF