Bug report #5282

crssync not executed in debian postinst nor when "make install" is run

Added by Etienne Tourigny over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Projection Support
Affected QGIS version:master Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:No Copied to github as #:15002

Description

the new crssync utility is not run in key moments - debian installs and 'make install'. It is important that it be executed in order to avoid many problems with crs assignment (see bug #4977)

1)
There is a statement in bug #4977 that crssync is run in post inst, but I can't find where...

I have examined the debian config files and I do not see any reference to "crssync", contrary to the osgeo4w install script.

I have also built .deb files for 1.8 and there is nothing special in the (auto-generated) postinst scripts.

2)
crssync should be part of the "make install" scripts, because srs.db gets installed each time but any sync gets overwritten.

3)
Can crssync be back-ported to 1.7, or at least install an updated srs.db? (see bug #4977)

4)
It would be good to have an interface in Options (CRS tab) to run "crssync".

crssync-install.patch Magnifier (3.62 KB) Etienne Tourigny, 2012-04-02 04:42 PM

History

#1 Updated by Jürgen Fischer over 9 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

- call in postinst added in commit:1011198 and 520e488.
- AFAIK there won't be another release of 1.7
- only root can update the srs.db, so a UI wouldn't work (easily)
- not sure about running crssync on 'make install'

#2 Updated by Etienne Tourigny over 9 years ago

Jurgen - thanks

please consider this patch which adds CRS_SYNC[=TRUE] option. After installing *.db files, crssync is run.

This is disabled in the debian/rules file by adding -D CRS_SYNC=FALSE (so it isn't done at package building but at postinst)

Also available in: Atom PDF