Bug report #528

QGIS does't remove GRASS mapset lock file after its session

Added by Redmine Admin almost 14 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:Linux Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:10587

Description

Steps to reproduce:
1. Start QGIS (from clean console, not from GRASS!) and open existing mapset
2. Close QGIS
3. Start QGIS again and try to open the same mapset which was opened in step 1. Now it's not possible because the maset is still locked.
This happened only if QGIS is not started from GRASS.

History

#1 Updated by Gary Sherman almost 14 years ago

I wasn't able to duplicate this. My mapset was not locked after following the steps.

#2 Updated by Redmine Admin almost 14 years ago

It works for me in WINDOWS and if QGIS is started from GRASS otherwise .gislock file remains in mapset directory and it is not possible to use the mapset again. (btw. in Windows there were no lock file created during mapset use)

#3 Updated by Tim Sutton almost 14 years ago

Moved to milestone 0.8.2 since we wont be fixing any further issues before the 0.8.1 release

#4 Updated by Gary Sherman over 13 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

This appears to work in both 0.8.1 branch and 0.9

#5 Updated by Anonymous over 11 years ago

Milestone Version 0.8.2 deleted

Also available in: Atom PDF