Bug report #5272

Symbol level dialog causes QGIS crash

Added by Alessandro Ciali over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System:window Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed
Crashes QGIS or corrupts data:Yes Copied to github as #:14997

Description

Attemping to access to symbol level dialog from layer properties of a polygon shape layer causes QGIS crash.

geologia.7z (26.6 KB) Alessandro Ciali, 2012-04-01 12:14 AM

History

#1 Updated by Giovanni Manghi over 10 years ago

  • Status changed from Open to Feedback

cannot replicate here, can you please attach sample data and exact steps? thanks.

#2 Updated by Alessandro Ciali over 10 years ago

step 1: load data with legend loaded as default in QGIS Master
step2: open properties dialog for layer RU_st018poly
step3: from Style -> advanced -> symbol levels

QGIS crashes immediately with the following window message:
'QGIS.exe ha smesso di funzionare
Si è verificato un problema che impedisce il corretto funzionamento del programma. Chiudere il programma.'

I'm sending the shp RU_st018poly for you to reproduce the error.
Thank, best regards
Alessandro

#3 Updated by aperi2007 - over 10 years ago

I try using the
qgis-dev 157541e (01/04/2012)
(very nice the
Using the shapefile given opening the properties->style->advanded->symbol-level.
I cannot reproduce the bug.
Perhaps some other conditions or global setting on qgis to do it ?

I'm using win7 64bit.

#4 Updated by Giovanni Manghi over 10 years ago

Perhaps some other conditions or global setting on qgis to do it ?

please check if there is any 3rd party plugin that is interfering. Try backup and delete the .qgis folder and give it a try again. Thanks.

#5 Updated by Alessandro Ciali over 10 years ago

Hi,
I renamed .qgis folder but never has changed. I think the problem is not depending on some plugin.
Under Qgis 1.7.4 i can access to the symbol level menu without problem for the same layer I sent to you.
I also tryed to uncheck one by one the option in the rendering tab (option menu), but It seems non to be related with the problem.
I don't know where is the problem :(.

#6 Updated by Giovanni Manghi over 10 years ago

Alessandro Ciali aciali wrote:

Hi,
I renamed .qgis folder but never has changed. I think the problem is not depending on some plugin.
Under Qgis 1.7.4 i can access to the symbol level menu without problem for the same layer I sent to you.
I also tryed to uncheck one by one the option in the rendering tab (option menu), but It seems non to be related with the problem.
I don't know where is the problem :(.

can you please test on another machine and report back? So we can understand if is a local problem. Thanks.

#7 Updated by Alessandro Ciali over 10 years ago

I experienced this bug in 2 computer both of them with AMD 64 processor, Win 7 64bit. In both cases QGIS Master produced the error, while QGIS 1.7.4 worked fine. Unfortunately in this moment I haven't other computer/systems to test the bug, if I'll get one I'll try. Anyone can test this error on other systems?

#8 Updated by Jürgen Fischer over 10 years ago

Are trying with the categorized renderer with "Display classification attribute names in legend" enabled in options? Then this should be fixed with fbdebd1e

#9 Updated by Alessandro Ciali over 10 years ago

Yes it is. I'll try the new version as soon as possible. Thanks,
Alessandro

#10 Updated by Alessandro Ciali over 10 years ago

Tested c367a35, symbol level dialog seems to work as aspecteced, I suggest to close the ticket.
Thanks,
Alessandro

#11 Updated by Giovanni Manghi over 10 years ago

  • Resolution set to fixed
  • Status changed from Feedback to Closed

Also available in: Atom PDF