Bug report #5231

QGis crashes on Gradual styling

Added by Victor Mensing over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:14967

Description

There are made significant improvements on saving styling on legends in QGis 1.7.4 vs 1.7.3, but if when chosen for saving a gradual legend on a large theme QGIS still crashes.

Clipboard01.jpg (53.2 KB) Victor Mensing, 2012-03-26 12:42 AM

History

#1 Updated by Giovanni Manghi over 9 years ago

on what platform? can you please post a sample dataset that causes the issue? thanks.

#2 Updated by Victor Mensing over 9 years ago

I use QGis 1.7.4 on Windows XP. The attached file is an export from the theme I used. I can't reproduce the crash with this file, so it seems it's more related to the case that the original data comes from an POSTGIS-theme. To reproduce my crash I think you better can export the shape again to postgis (using SRID 28992).

#3 Updated by Victor Mensing over 9 years ago

It seems my ZIPPED datafile is too large to attach. I will send it to you with a service.

#4 Updated by Giovanni Manghi over 9 years ago

  • Category set to Symbology

Hi, thanks for the sample.

It works fine here as both shape and postgis layer, using qgis-development version.

Can you give it a go installing qgis-dev on Windows using osgeo4w? Thanks.

#5 Updated by Giovanni Manghi over 9 years ago

  • Status changed from Open to Feedback

#6 Updated by Giovanni Manghi over 9 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

Closing for lack of feedback. Reopen if necessary.

#7 Updated by Victor Mensing over 9 years ago

I lost my password on this environmnet and was unable to ask for a new password. So i created a new account tot end this bug-report. I still had the crash. Also the first time running the newest (developers-version) of QGis.

Because of a computer crash I uses another laptop and since then I ws not able to reproduce the bug. So it stays uncleared why I had the crash.

#8 Updated by Giovanni Manghi over 9 years ago

Victor Mensing wrote:

I lost my password on this environmnet and was unable to ask for a new password.

the ID used here is an OSGeo id, there isn't a password recovery tool in the osgeo.org website?

So i created a new account tot end this bug-report. I still had the crash. Also the first time running the newest (developers-version) of QGis.
Because of a computer crash I uses another laptop and since then I ws not able to reproduce the bug. So it stays uncleared why I had the crash.

so we can assume it is/was a local issue? Did you a try to make a very clean install in your environment? I mean: remove .qgis, remove the program, remove the registry keys and then install again.

#9 Updated by Victor Mensing over 9 years ago

I'm not sure about that. And I'm still waiting to get back my old laptop to reproduce some things. So till then I can't figure it out clearly. Better is to close this issue for now and wait till I can get back with new information when possible.

Also available in: Atom PDF