Bug report #51

Open file and view by extension

Added by anonymous - over 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Gary Sherman
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Gentoo Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10110

Description

1)Select Open Raster or Vector

2)Go in a folder with only one kind of file (for example .shp)

3)File are correctly showned

4)Change the file type (example MapInfo file)

5)Switch back to the type of file in point 2

6)No file is showned

The same happen with raster file.

History

#1 Updated by Gavin Macaulay - over 14 years ago

What version of Qt are you using? It works for me with Qt 4.1.1

#2 Updated by balazovic-mailbox-sk - over 14 years ago

I've observed similar issue with a little bit different steps:

1. Select Add Raster or Vector

2. Change File filter to All files (*.*)

3. Select and open some file

4. Select Add Raster or Vector

5. File filter is set to All files (*.*) but there are displayed only files of (previous) filter.

Compiled against Qt 4.1.0

#3 Updated by Luca - over 14 years ago

Using QT 4.1.2

#4 Updated by Redmine Admin over 14 years ago

It's getting worse - in QGIS compiled against Qt 4.1.2 even directories are sometimes not listed :-(

#5 Updated by Gavin Macaulay - over 14 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

This is a bug in Qt 4.1.1 and 4.1.2 (see http://www.trolltech.com/developer/tasktracker.html?method=entry&id=106783).

It will be fixed in Qt 4.1.3 (or so it says on the above page).

#6 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF