Bug report #503

GUI messages completely illegible

Added by carluti - over 13 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10562

Description

All messages in menu bars, windows, etc. seem to have lots of letter mixed.

Pantallazo.png (93.2 KB) carluti-users-sourceforge-net -, 2007-01-01 09:13 AM

History

#1 Updated by carluti-users-sourceforge-net - over 13 years ago

Partially reproduced in another pc using also debian etch. Menu bar entries look fine, but layer names in leyend and texts in some windows have the same problem.
Both pc are used in Spanish and qgis is also in Spanish.

#2 Updated by Gavin Macaulay - over 13 years ago

What version of Qt is qgis compiled and running against (this information is available via the Help:About menu, About tab)?

Have you compiled qgis or used a package (if so, which one)?

Does the problem happen with the english translation?

#3 Updated by Redmine Admin over 13 years ago

It does not happen here, neither with it_IT nor with es_ES locales. Please provide more details.

#4 Updated by anonymous - over 13 years ago

Replying to [comment:3 g_j_m]:

What version of Qt is qgis compiled and running against (this information is available via the Help:About menu, About tab)?
Quite difficult to read, but it seems to be Qt 4.2.1
Have you compiled qgis or used a package (if so, which one)?

Using gfoss 0.8.0 package

Does the problem happen with the english translation?

export LANG=en_EN give same problem in the first computer. Tomorrow will try the other.

#5 Updated by carluti-users-sourceforge-net - over 13 years ago

Replying to [comment:6 anonymous]:

Replying to [comment:3 g_j_m]:

What version of Qt is qgis compiled and running against (this information is available via the Help:About menu, About tab)?

Quite difficult to read, but it seems to be Qt 4.2.1

Have you compiled qgis or used a package (if so, which one)?

Using gfoss 0.8.0-2 package

Does the problem happen with the english translation?

export LANG=en_EN gives same problem in the first computer. Tomorrow will try the other.

Confirmed in both machines. A third one with similar installation works fine.
What other information would be relavant to guess where is the problem?

#6 Updated by carluti-users-sourceforge-net - over 13 years ago

Behaviour is very extrange. After working for some time on a project or creating new projects for test, menu bar, leyend, status bar and most windows displays correctly all text, but after closing qgis and reopening it, again texts appear illegible.
Any explanation?

#7 Updated by Redmine Admin over 13 years ago

I can confirm the bug, and its curious behaviour. It does not appear to be dependent on the hardware (only one of 5 IBM thinkpad had that problem) or the software (apparently same installation on 10 machines, only 2 showed it), or the desktop environment (not working: 1 on gnome, 1 on kde).

#8 Updated by Redmine Admin over 13 years ago

(untested)
It has been reported that this depends on a QT bug. A workaround could be copying a .fonts.conf file on each home (see below), but surely there is a better solution. I report this here just to help solving the problem.

file: .fonts.conf

<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<match target="font" >
<edit mode="assign" name="rgba" >
<const>none</const>
</edit>
</match>
<match target="font" >
<edit mode="assign" name="hinting" >
<bool>true</bool>
</edit>
</match>
<match target="font" >
<edit mode="assign" name="hintstyle" >
<const>hintfull</const>
</edit>
</match>
<match target="font" >
<edit mode="assign" name="antialias" >
<bool>true</bool>
</edit>
</match>
</fontconfig>

#9 Updated by carluti-users-sourceforge-net - over 13 years ago

Replying to [comment:10 ]:

I have used your solution in both machines I had this problem and now Qgis works well in both of them.
Thank you

#10 Updated by anonymous - over 13 years ago

Hi all,

I've got the same problem, the "editing of fonts.conf" solution proposed worked pretty well!!!

Thanks a lot!

Enrico Guastaldi
Geomatics Lab, Geological Risks and Geostatistics section
Centro di GeoTecnologie, University of Siena,
Via Vetri Vecchi, 34
52027 - San Giovanni Valdarno (AR)
ITALY

Tel. +39 055 9119483
Fax. +39 055 9119439

www.geotecnologie.unisi.it

Replying to [comment:11 ]:

Replying to [comment:10 ]:

I have used your solution in both machines I had this problem and now Qgis works well in both of them.
Thank you

#11 Updated by Tim Sutton over 13 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Reading the messages above you seem to have the issue resolved. I am closing this bug - please reopen if the problem persists.

#12 Updated by Anonymous about 11 years ago

Milestone Version 0.8.1 deleted

Also available in: Atom PDF