Bug report #5016

postgis provider problem with identify map tool

Added by Richard Duivenvoorde over 9 years ago. Updated over 9 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Data Provider/PostGIS
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14792

Description

Running master (14/2/2012) I have a problem with the identify map tool.

If I run it in the normal modus it works ok (for this postgis layer), but if I run it in the modus 'Open feature form, if a single feature is identified' from the Maptools tab in the Options. I get the wrong results.

To reproduce:
- loaded attached shape in postgis via SPIT plugin (using epsg:28992 as CRS)
- load the layer in QGIS
- using the identify tool in normal modus: every point shows you city information
- uding the identify tool in 'open feature form' modus, a form is opened, but it is showing the wrong information. It shows the feature with apparently gid 1

plaatsen.zip - shape file with points in epsg:28992 (4.16 KB) Richard Duivenvoorde, 2012-02-14 09:48 AM

Associated revisions

Revision d2775ba5
Added by Jürgen Fischer over 9 years ago

fix 659abb8d (fixes #5016)

History

#1 Updated by Jürgen Fischer over 9 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF