Bug report #4958

SL provider crs() method returns nearly always a custom CRS

Added by Giuseppe Sucameli over 8 years ago. Updated over 8 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:14753

Description

The SL provider uses proj4string from internal spatial_ref_sys table instead of srid to create a crs.
Since QGis crs-db contains modified CRSs (proj4 strings have a +towgs84 param) most of the SL layers has a custom CRS so when executing layer.crs().postgisSrid() returns 0 instead of the correct CRS.

Associated revisions

Revision 6878bf1b
Added by Jürgen Fischer over 8 years ago

spatialite provider: prefer auth_id over proj4 string (fix #4958)

History

#1 Updated by Jürgen Fischer over 8 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Also available in: Atom PDF