Feature request #4855

Improve curved labels

Added by Giovanni Manghi over 7 years ago. Updated over 7 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Labelling
Pull Request or Patch supplied:No Resolution:duplicate
Easy fix?:No Copied to github as #:14688

Description

It is easy to see that if a curved line is "perfect" (example: an arc done with the "cad tools" plugin) then the curved labels are correctly rendered. If the curved line is quite smooth but made of just a few nodes, then the curved labels are not rendered as expected.

As an example of working curves use the attached shape. As an example of not working curves you can use https://issues.qgis.org/attachments/4183/labels_test.zip

linha_shp.zip (103 KB) Giovanni Manghi, 2012-01-23 05:26 AM

08.png (463 KB) Giovanni Manghi, 2012-01-23 05:26 AM

27.png (462 KB) Giovanni Manghi, 2012-01-23 05:26 AM

History

#1 Updated by Martin Dobias over 7 years ago

  • Assignee deleted (Martin Dobias)

Actually the problem is elsewhere: if the label width does not fit to the linestring length, it will not be added with curved placement. A solution could be to have an option to place the labels even if they do not fit - the engine would pretend that the first and last segment are "infinite"

#2 Updated by Giovanni Manghi over 7 years ago

Martin Dobias wrote:

Actually the problem is elsewhere: if the label width does not fit to the linestring length, it will not be added with curved placement. A solution could be to have an option to place the labels even if they do not fit - the engine would pretend that the first and last segment are "infinite"

I would be happy to give it a try.

#3 Updated by Giovanni Manghi over 7 years ago

  • Target version changed from Version 1.8.0 to Version 2.0.0

#4 Updated by Giovanni Manghi over 7 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

duplicate of #2113

Also available in: Atom PDF