Bug report #482

Incorrect point placement

Added by Redmine Admin almost 14 years ago. Updated almost 14 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:duplicate
Crashes QGIS or corrupts data: Copied to github as #:10541

Description

I am using QGIS to project pointfiles onto a map of Australia. The map I am using is the shapefile published by Geosciences Australia (www.ga.gov.au). The points I am importing are decimal latitude/longitude points (see below signature), imported using the text importer.

What happens is that some or all of the points are imported with the latitude sign inverted (ie, from - to +), placing the points above the equator instead of below.

If I import the delimited text file with no header row, then the sign inversion happens on the first entry only. If I import the text file with a header row, then the inversion is applied to all of the latitude entries.

Richard Chirgwin

The imported dataset:
-37.9909 145.2131
-37.9238 145.1203
-37.9061 144.6449
-37.8138 144.963
-37.7893 144.8343
-37.7848 145.1241
-37.6856 144.921
-37.6756 144.6118
-37.6323 145.0847
-35.0067 138.5446
-34.9797 138.5198
-34.9606 138.6338
-34.9591 138.6125
-34.9461 138.5308
-34.8981 138.5969
-34.8825 138.5943
-34.882 138.6824
-34.8761 138.5381
-34.8367 138.5125
-34.829 138.5989
-33.9545 151.1144
-33.9291 151.1879
-33.9181 151.1634
-33.9164 151.2365
-33.8984 151.1783
-33.8977 151.2035
-33.8944 151.1344
-33.8857 151.1259
-33.8857 151.0283
-33.884 151.1493
-33.8746 151.2228
-33.8385 151.2065
-33.8161 151.0909
-33.7326 151.0416
-27.5404 153.0693
-27.5094 153.1106
-27.483 152.9829
-27.4125 152.9501
-27.4119 153.0101
-27.3989 153.1052

History

#1 Updated by Gavin Macaulay - almost 14 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

Duplicate of ticket #481

Also available in: Atom PDF