Bug report #4752

Crash when zooming

Added by MRick - almost 9 years ago. Updated over 8 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Labelling
Affected QGIS version:master Regression?:No
Operating System:Mac OS X 10.6.8 Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:Yes Copied to github as #:14621

Description

Hi

I have a file in which i rendered bus lines. I set the 'ref' field as a text layer.
When I zoom, QGIS will crash whatever the version is.
It will not crash if I change the text layer value from 'ref' to 'name' or any other field when i am zooming.
Strange, do you mind what could happen?
It is strange, why for a value, not another?

The lines are rendered as rules set as follow:
((line = 'bus') AND (ref = '16'))

I give you the file, but I doubt it will be useful without the right database, but I join you the data set.

<http://www.box.com/s/nibrax4ag5cyvt6vor13>

crash_log.txt Magnifier (51.3 KB) MRick -, 2012-01-06 01:55 AM

Archive.zip (205 KB) MRick -, 2012-01-19 02:21 AM

History

#1 Updated by Martin Dobias almost 9 years ago

The crash log suggest that the error happens in the labeling code.

Could you please try to save your layer to a common format (e.g. shapefile) and prepare a project that triggers the crash? I don't know how to easily load the data you have provided.

#2 Updated by MRick - almost 9 years ago

Hi this is the crashing test base in shape files.

#3 Updated by Giovanni Manghi almost 9 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Priority changed from Normal to High

#4 Updated by Martin Dobias over 8 years ago

  • Category changed from Browser to Labelling

I am unable to reproduce (linux, master branch) with the attached data. Anyone else does?

#5 Updated by Giovanni Manghi over 8 years ago

  • Status changed from Open to Feedback

#6 Updated by Giovanni Manghi over 8 years ago

  • Resolution set to invalid
  • Status changed from Feedback to Closed

Closing for lack of feedback. Please reopen if necessary, attaching a project with the layers, symbology and labelling options to trigger the problem. Try also removing any 3rd party plugin if something changes.

Also available in: Atom PDF