Bug report #469

WinQGIS: Cannot load gpx files

Added by Redmine Admin almost 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Tim Sutton
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10528

Description

In Windows: If I use the plugin GPS->Create a new gpx file it say to choose a path and a name for the .gpx file but when I choose it it say: The layer is not a valid layer and can not be added to the map

History

#1 Updated by Gavin Macaulay - almost 14 years ago

Qgis is creating the gpx file, but not loading it. It works under linux. The code that is probably failing involves reading the .gpx file using an XML parser (expat?). Perhaps the windows version of that is causing the problem?

In fact, the windows version won't load any of my .gpx files, while the linux version does.

#2 Updated by Gavin Macaulay - over 13 years ago

The problem seems to be that the gps provider dll is not present (but the gps plugin dll is).

#3 Updated by Tim Sutton over 13 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in revision 6377

#4 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF