Bug report #4559

Cutting tool for line

Added by Gilles Turgeon almost 8 years ago. Updated over 7 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:14472

Description

When I use the tools for separate entity, I expect to obtain 2 entities. But if the line cross itself at some(s) place(s), I obtain a new entity between each crossing point. The line act as a cutting tool applied to itself.

I don't know if it's a bug or if this comportement is what you expect. For me it's a bit annoying. I edit line that come from a GPS receiver held by hiker. When they stop during the survey, and they often do, the GPS accumulate a lot of point almost at the same position, creating a lot of self-crossing. When I cut anywhere on this line, QGis separate the entity in a very big lot of entities.

test.zip - test track which becomes 15 pieces after cutting in half (from mailinglist) (2.16 KB) Richard Duivenvoorde, 2011-11-22 06:49 AM

History

#1 Updated by Richard Duivenvoorde almost 8 years ago

not sure if this your are the same person, but someone had this issue also on the list:

http://lists.osgeo.org/pipermail/qgis-user/2011-November/014413.html

I'll attach that test shape to this note

#2 Updated by Giovanni Manghi almost 8 years ago

Richard Duivenvoorde wrote:

not sure if this your are the same person, but someone had this issue also on the list:

http://lists.osgeo.org/pipermail/qgis-user/2011-November/014413.html

I'll attach that test shape to this note

The line is also split in every self-intersection point.

#3 Updated by Giovanni Manghi almost 8 years ago

  • Category set to Digitising

#4 Updated by Giovanni Manghi over 7 years ago

  • Target version set to Version 1.7.4

#5 Updated by Giovanni Manghi over 7 years ago

  • Crashes QGIS or corrupts data set to No
  • Status changed from Open to Closed
  • Resolution set to duplicate
  • Affected QGIS version set to master

Duplicate of #4087

Also available in: Atom PDF