Bug report #453

Identify dialog creeps up with each use

Added by Gary Sherman almost 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Gary Sherman
Category:GUI
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10512

Description

Identify a feature. Close the identify dialog. Repeat. The dialog creeps up by what appears to be the height of the window title bar.

This is a problem on Windows, not tested on other platforms.

History

#1 Updated by Gavin Macaulay - almost 14 years ago

Works ok on Linux. Is this really critical?

#2 Updated by Gary Sherman almost 14 years ago

It's critical because eventually the dialog walks its way off the top of the screen and the user has to battle to get it back. And you may not notice whats going on until the title bar is off the screen.

#3 Updated by anonymous - almost 14 years ago

This looks like a bug in the latest version of Qt for Windows (I've seen it before...)

-gsherman

#4 Updated by Gavin Macaulay - almost 14 years ago

Interestingly, on a different linux setup (display via an X server on windows), the identify results dialog box goes down with each iteration.

#5 Updated by Gary Sherman almost 14 years ago

Thats going to make it fun to fix. This must be a Qt bug since the same code worked fine previous to recent Qt (at least I think it did).

#6 Updated by Gavin Macaulay - almost 14 years ago

Possible fix in af433383 (SVN r6256). Please test.

#7 Updated by Gary Sherman almost 14 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

Works for me.

#8 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF