Bug report #4515

Rendering issue with almost cohincident lines

Added by Sandro Santilli almost 10 years ago. Updated almost 10 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:-
Affected QGIS version: Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data: Copied to github as #:14434

Description

The following WKT has a few rendering problems.
It is a V shaped figure. One element is the full V, the other two are the two wings.
The bottom node is cohincident for the two wings, but it's moved on the left for the full V.

If you zoom in the upper-left corner you clearly see two lines.
If you zoom in the lower corner the line on the left becomes ONE and the one on the right become TWO.

This is with a recent build from master, and specifically be9bdeb

MULTILINESTRING(
(
832709.937 816560.25,
832705.813 816470.25,
832661.937 816561.875
),
(
832705.812 816470.25,
832709.937 816560.25
),
(
832661.938 816561.875,
832705.813 816470.25
))

See also ticket #4515

History

#1 Updated by Sandro Santilli almost 10 years ago

The actual input shape (was different than I thought)

#2 Updated by Sandro Santilli almost 10 years ago

  • Resolution set to invalid

Now that we know the shape of the input, it turns out this is NOT a bug.
Thanks for listening ;P

#3 Updated by Sandro Santilli almost 10 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF