Bug report #445

qgis crash deleting point in postgis table

Added by venturato-faunalia-it - almost 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Digitising
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10504

Description

When we try to delete a point in postgis table qgis crash:

Warning: QPainter::begin: Painter already active
Segmentation fault

This happens every time we allow editing, select a point, and click on the "cut" icon. It doesn't happen with linestring or polygon.

The problem is similar to http://svn.qgis.org/trac/ticket/132

I don't know if it's could be correlate, but connection to db seems lower than before.

History

#1 Updated by anonymous - almost 14 years ago

Works for me.

Can you provide a backtrace from the crash?

#2 Updated by Marco Hugentobler almost 14 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Made QgsVectorLayer and QgsFeature more robust against 0 geometry objects.

#3 Updated by venturato-faunalia-it - almost 14 years ago

  • Status changed from Closed to Feedback
  • Resolution deleted (fixed)

The bug fixing caused a side effect:
If I try to select from query builder on a table (I tried also as db superuser with full grants) I get an error message: 'Connection to database failed: FATAL: password authentication failed for user "username"'.
Furthermore, if I select all records from a table with missing geoms, then zoom to selection, qgis crashes. If I exclude the records with missing geoms, the zoom works well (no crash). So missing geoms appear to be a problem not only for digitizing, but also for selecting.
The query builder might be a side effect?

#4 Updated by venturato-faunalia-it - almost 14 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

fixed now

#5 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF