Bug report #437

Crash on GRASS browser refresh

Added by Martin Dobias almost 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Redmine Admin
Category:GRASS
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10496

Description

Steps to reproduce:
1. delete first vector map
2. create a map (e.g. doing a buffer) and give it a similar name so it should get to the same position in the grass browser
3. refresh grass browser

History

#1 Updated by Redmine Admin almost 14 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Fixed in revision 6250.

The problem was that Qt can call
QgsGrassModel::index( int row, int column, const QModelIndex & parent )
with row < 0 (strange/bug/correct?) for example if beginInsertRows(,0,0)
is called and the first item was previously deleted
=> check if row < 0 and return empty QModelIndex, but is it correct?

Radim

#2 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF