Bug report #424

QGIS 0.8 Preview 2 project with PostGIS Layer is not reloadable

Added by Redmine Admin almost 14 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Gavin Macaulay -
Category:Project Loading/Saving
Affected QGIS version: Regression?:No
Operating System:RedHat Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:10483

Description

A prject saved with QGIS 0.8 Preview 2 containing a PostGIS layer is not reloadable. The PostGIS provider responses with an error message:
ERROR: zero-length delimited identifier at or near """" at character 15
.
SQL: select * from "" limit 1

The reason of this message is a change of the project file syntax.
QGIS 0.8 Preview 2:
<datasource>host=localhost dbname=sogis port=5432 user=username password= table=public.standort (wkb_geometry) sql=archive=0</datasource>

changed to
QGIS 0.8 Rev 6193
<datasource>host=localhost dbname=sogis port=5432 user=username password= table="public"."standort" (wkb_geometry) sql="archive"=0</datasource>

Adding the double quotes let QGIS 0.8 Rev 6193 load the project.

History

#1 Updated by Gavin Macaulay - almost 14 years ago

  • Status changed from Open to In Progress

#2 Updated by Gavin Macaulay - almost 14 years ago

  • Resolution set to fixed
  • Status changed from In Progress to Closed

Fixed in svn 17090c65 (SVN r6200)

#3 Updated by Anonymous about 11 years ago

Milestone Version 0.8 deleted

Also available in: Atom PDF